Anmelden AnmeldenSchließen
| Passwort vergessen?
Reit- und Wanderkarte
Forum | Registrieren | Suche      Anmelden     1 Benutzer online
Mapsource-Registry fehlt.
 1 2 3 4 5
24.11.15 18:21
waheiss 
Re: Mapsource-Registry fehlt.

Hallo, WWAK, Nope,
nachdem die Registry Einträge alle sauber eingetragen sind, funktioniert die Kartendarstellung. Die Einträge brauchen ja wohl nur 1x vorgenommen zu werden, sofern man immer auf den Eintrag Beispielkarte generiert. Dafür schon mal Dankeschön.
Habe aber noch ein anderes Problem, was ich auch bei Win7 hatte. Es werden im Composer immer 2 img-Dateien erzeugt.
Als Beispiel: 740000.img und 740001.img. Wenn beide Dateien im Composer-Verzeichnis bleiben, dann zeigt mir Basecamp nur Autobahnen und Bundesstraßen an. Lösche ich die 740000.img und benenne die 740001.img in 740000.img um, dann wird die Karte mit allen Wegen angezeigt.
Da scheint auch noch was falsch zu laufen.
Gruß waheiss

24.11.15 19:58
Nop 

Administrator

Re: Mapsource-Registry fehlt.

WWAK:
das RegFile war jedes Mal i.O. Die automatische Übertragung in die Registry hat allerdings bei allen 3 Versuchen nicht geklappt, Fehler war immer:
24.11.15 09:14 Registry install call failed!

Das klingt jetzt eindeutig nach einem Rechteproblem. Ich arbeite leichtsinnigerweise immer als Admin-User. Verwendest Du einen Admin-User oder einen User mit eingeschränkten Rechten?

Falls es das ist kann ich aber nicht sagen ob es dann überhaupt möglich ist, von Java aus in die Registry zu schreiben.

Zur Not bleibt immer die Methode die .reg-Datei einfach per Rechtsklick von Hand in die Registry zu installieren. Oder die Zeile mit dem "reg import" in der commands.log in eigene Datei zu kopieren und auszuführen. Das könnte man dann sogar als Admin ausführen.

Vielleicht sollte ich noch einen Hinweis anzeigen, wenn der import nicht klappt, anstatt es nur in die Logdatei zu schreiben.

bye, Nop

24.11.15 20:06
Nop 

Administrator

Re: Mapsource-Registry fehlt.

waheiss:
Habe aber noch ein anderes Problem, was ich auch bei Win7 hatte. Es werden im Composer immer 2 img-Dateien erzeugt.
Als Beispiel: 740000.img und 740001.img. Wenn beide Dateien im Composer-Verzeichnis bleiben, dann zeigt mir Basecamp nur Autobahnen und Bundesstraßen an. Lösche ich die 740000.img und benenne die 740001.img in 740000.img um, dann wird die Karte mit allen Wegen angezeigt.

Die Karte kann aus sehr vielen Kacheln bestehen, die sind dann fortlaufend nummeriert <ID>0001.img, <ID>0002.img, <ID>0003.img usw.

Die Kachel <ID>0000.img ist die Übersichtskarte, die wird immer zusätzlich erzeugt und enthält nur größere Straßen und Wasserflächen.

Was Du also gemacht hast, ist die Übersichtskarte von gelöscht und Deine eigene Karte, die zufällig so klein ist, daß sie in eine Kachel paßt, als Übersichtskarte angegeben.

Die Frage ist natürlich warum Deine Karte nicht so angezeigt wird.
- hast Du die Einträge in der Registry von Hand erzeugt oder die von Composer erzeugte Datei verwendet?
- ist der Eintrag "Loc" in der Registry richtig gesetzt?

bye, Nop

25.11.15 08:20
waheiss 
Re: Mapsource-Registry fehlt.

Hallo, Nop,

Nop:

- hast Du die Einträge in der Registry von Hand erzeugt oder die von Composer erzeugte Datei verwendet?


Habe den Composer und das Starthilfe-Set in ein extra Verzeichnis gepackt und über Start.bat gestartet. So wie es in der Anleitung beschrieben ist.
Die Meldung "Autokonfiguration erfolgreich ausgeführt" ist dann auch erschienen.

Nop:

- ist der Eintrag "Loc" in der Registry richtig gesetzt?


Wo finde ich den Eintrag in der Registry? Bin nicht der Experte und brauche die Pfade, wo ich was finde.

Gruß waheiss

25.11.15 20:44
Nop 

Administrator

Re: Mapsource-Registry fehlt.

waheiss:
Habe den Composer und das Starthilfe-Set in ein extra Verzeichnis gepackt und über Start.bat gestartet. So wie es in der Anleitung beschrieben ist.
Die Meldung "Autokonfiguration erfolgreich ausgeführt" ist dann auch erschienen.

Das war nicht gemeint. Die Karte muß nach dem Erzeugen in die Registry eingetragen werden, samit sie in Basecamp sichtbar wird.

Hast Du das
- von Composer erledigen lassen?
- die .reg Datei von Hand ausgeführt?
- es mit anderen Tools oder von Hand erledigt?

bye, Nop

26.11.15 06:54
waheiss 
Re: Mapsource-Registry fehlt.

Hallo, Nope,
eine Reg.-Datei befindet sich im Composerverzeichnis data.
Weitere Einträge dazu auch in der Registry.
Alles wurde durch den Composer automatisch angelegt.
Gruß waheiss

Datei-Anhänge
Reg.jpg Reg.jpg (2x)

Mime-Type: image/jpeg, 98 kB

Reg1.jpg Reg1.jpg (2x)

Mime-Type: image/jpeg, 37 kB

28.11.15 21:53
Nop 

Administrator

Re: Mapsource-Registry fehlt.

Hm, dann verstehe ich nicht, warum er die Kartenkacheln bei Dir nicht anzeigt. Du bist der erste mit diesem Problem.

Hast Du's schon mal mit rein- und rauszoomen probiert?

bye, Nop

28.11.15 22:03
waheiss 
Re: Mapsource-Registry fehlt.

Ja hab ich.

waheiss:
Als Beispiel: 740000.img und 740001.img. Wenn beide Dateien im Composer-Verzeichnis bleiben, dann zeigt mir Basecamp nur Autobahnen und Bundesstraßen an. Lösche ich die 740000.img und benenne die 740001.img in 740000.img um, dann wird die Karte mit allen Wegen angezeigt.

Beide Anzeigen bekomme ich nur mit Zoomen.
Wenn es denn das 1. mal eingestellt ist, dann kommen die Karten auch beim Neustart sofort. Vielleicht liegt der Fehler ja beim BaseCamp-Programm.

Gruß waheiss

29.11.15 11:48
WWAK 
Re: Mapsource-Registry fehlt.

Hallo Waheiss,

ich hab nochmal eine Frage zu dem Problem mit der WIN 10 Registrierung:

Hat es mit der Kartenregistrierung aus dem Composer Programm jetzt geklappt oder hast du die +.reg Datei manuell in die Registry eingetragen?
Wenn es über das Programm geklappt hat, was hast du geändert oder ergänzt? Bei mir geht es nach wie vor nur mit "manuellem" Eintrag.

Gruß

WWAK

29.11.15 12:45
waheiss 
Re: Mapsource-Registry fehlt.

Hallo, WWAK,
habe nach Deinem Post vom 23.11.15 13:27 die Schlüssel manuell in die Registry eingetragen.
Als ich dann anschließend eine neue Karte im Composer erzeugt habe, hat sich der neue Reg.-Eintrag automatisch angelegt.
Siehe Bild 26.11.15 06:54

Aber das andere Problem mit der Kartendatei 740000.img und 740001.img ist noch nicht gelöst. Hast Du da vielleicht eine Idee.

Gruß waheiss

 1 2 3 4 5
Forum | Registrieren | Suche
Powered by: phpFK - PHP-Forum ohne MySQL 8.0 | Download | Alternativ: phpFK