Anmelden AnmeldenSchließen
| Passwort vergessen?
Reit- und Wanderkarte
Forum | Registrieren | Suche      Anmelden     2 Benutzer online
Seltsame Autobahndarstellung
 1 2
30.08.17 18:59
imap 
Seltsame Autobahndarstellung

Hallo zusammen,

meine ersten Versuche zur Kartenerstellung waren erfolgreich.
Allerdings habe ich in BaseCamp Darstellungsproblem mit Autobahnen. Es wird immer mindeststens eine weitere Spur, die mehr oder weniger "parallel", mitunter sogar schneidend die eigentliche Autobahn begleitet dargestellt (siehe Anhänge). Das gleiche Phänomen habe ich bei Erstellung der Beispielkarte (Oberfranken) mit "out of the Box-Einstellungen". Ob es außerhalb von BaseCamp funktioniert, weiß ich nicht.

Hat jemand eine Idee?

VG Andreas

Windows 10, Pro 1703, 64bit
Map Composer V0.95a
GmapTool v0.9
MapsetToolkit v1.77 Beta
Basecamp 4.6.2
Java 8 Update 91

Datei-Anhänge
autobahn1.jpg autobahn1.jpg (7x)

Mime-Type: image/jpeg, 42 kB

autobahn2.jpg autobahn2.jpg (4x)

Mime-Type: image/jpeg, 97 kB

31.08.17 21:33
Nop 

Administrator

Re: Seltsame Autobahndarstellung

Da kann ich mir keinen Reim drauf machen. Dort wo die kimischen Linien liegen ist keine Geometrie in den OSM Daten und nach fehlgeleiteten Höhenlinien sieht es auch nicht aus. Wenn es in weit voneinander entfernten Gegenden auftaucht kann es auch kein falsch eingetragenes und bereits wieder gelöschtes Element sein. Ich hab sowas noch nicht gesehen.

Wie sieht es denn in Oberfranken aus?

bye, Nop

31.08.17 22:16
imap 
Re: Seltsame Autobahndarstellung

Hallo Nop,

danke für Deine Antwort.
Im Anhang habe ich eine Ansicht der Beispielkarte Oberfranken angefügt.

Viele Grüße
Andreas

Datei-Anhänge
oberfranken.jpg oberfranken.jpg (4x)

Mime-Type: image/jpeg, 97 kB

01.09.17 12:43
imap 
Re: Seltsame Autobahndarstellung

Hallo,

ich habe mir die Mühe gemacht und Map Composer auf einem Ubuntu-Linux zum laufen gebracht.
Leider ändert das nichts an der Darstellung ... und auch in Kanada bauen die solch krummen Autobahnen.
Ich habe als Datenquelle sowohl Planetfile als auch osm.pbf-Dateien von GEOFABRIK benutzt.

VG
Andreas

01.09.17 14:19
imap 
Re: Seltsame Autobahndarstellung

Ich hab jetzt mit BaseCamp eine Karte auf meinem Garmin Oregon 700 installiert. Auf dem Gerät sieht alles so aus, wie es sein soll. Offensichtlich hat die aktuelle BaseCamp-Version 4.6.2 ein Problem?

VG
Andreas

01.09.17 14:31
Nop 

Administrator

Re: Seltsame Autobahndarstellung

Eher nicht - ich verwende auch 4.6.2 und habe keine solchen Effekte.

Daß es auf dem Gerät gut aussieht macht es noch merkwürdiger.

Hast Du in dem Basecamp noch andere Karten oder Daten wie Tracks, die irgendwie hineingemischt sein könnten?

bye, Nop

01.09.17 15:14
imap 
Re: Seltsame Autobahndarstellung

Es sind noch einige von den Freizeitkarten installiert, Tracks sind auch vorhanden, aber nicht über die Autobahnen. Die paar Tracks kann ich auch sauber ein/ausblenden. Wenn ich auf die Freizeitkarte umschalte, sieht alles gut aus.

VG
Andreas

01.09.17 23:22
imap 
Re: Seltsame Autobahndarstellung

Ich habe eine Lösung gefunden:
Bisher habe ich Map Composer unter meinem normalen User gestartet (start_x64.bat), da alle Optionen mit "Als Administrator ausführen" das Programm gar nicht erst starten ließen. Deshalb habe ich auch die Karten via MapsetToolkit in BC installiert. Starte ich jedoch eine Komanndozeile mit "Als Administartor ausführen", rufe daraus die start_x64.bat auf und aktiviere die "Basecamp Integration" im Job, wird die Karte gleich durch Map Composer für BC registriert und dann auch korrekt dargestellt! Jetzt muss ich noch eine bequeme 1-Click-Startumsetzung finden.

VG
Andreas

02.09.17 11:44
Nop 

Administrator

Re: Seltsame Autobahndarstellung

Das heißt es war irgendein Unterschied bei der Anmeldung mit MapSetToolkit?

Interessant zu wissen, ich habe MTK bisher nur zum Deinstallieren benutzt.

Welches OS verwendest Du daß der Aufruf mit Adminrechten Probleme macht und in welchem Verzeichnis hast Du Composer laufen?

bye, Nop

02.09.17 14:49
imap 
Re: Seltsame Autobahndarstellung

Hallo Nop,

MapSetToolkit habe ich immer mit expliziten Adminrechten ("Als Administrator ausführen") laufen gelassen, damit die Registryeinträge geschrieben werden konnten und ich überhaupt die Karte in BC sehen konnte.
Map Composer kann ich nicht direkt mit explizieten Adminrechten starten (Programm schließt sich gleich wieder) und somit auch nicht die Registryeinträger schreiben und auch nicht Karte in BC installieren lassen.
Nur indirekt über eine Komandozeile mit "Als Administrator ausführen" gelingt es mir Map Composer zu starten und die Registryeinträge schreiben zu lassen. MTK war für mich eher eine Notlösung, die ich nun nicht mehr brauche. Ich bin in meinem System zwar mit einem Administratoren-Konto angemeldet, das reicht anscheinend aber nicht aus. Erst wenn auch das Registry-schreibende Programm explizit mit der Option "Als Administrator ausführen" gestartet wurde oder durch ein entsprechenden Prozess, der die Rechte weitergibt, klappt die Installation korrekt für BC. Aber offensichtlich hat MTK / BC bei mir ein Problem mit Karten, die durch Map Composer ohne "Als Administrator ausführen" erstellt wurden. Ein weiteres UAC-Phänomen...

Hier die Infos meiner Softwareinfrastruktur:
Windows 10, Pro 1703, 64bit
Map Composer V0.95a
GmapTool v0.9
MapsetToolkit v1.77 Beta
Basecamp 4.6.2
Java 8 Update 91

VG
Andreas

 1 2
Forum | Registrieren | Suche
Powered by: phpFK - PHP-Forum ohne MySQL 8.0 | Download | Alternativ: phpFK